Back to overview
Downtime

Elevated 500s

Nov 18 at 02:06am HST
Affected services
merkle.io
mempool.merkle.io

Resolved
Nov 18 at 03:39am HST

We are seeing traffic levels back to pre-incident. We will continue to monitor the situation.

Updated
Nov 18 at 02:29am HST

We are seeing new intermittent 500s on mempool due to a Cloudflare outage.

Updated
Nov 18 at 02:19am HST

Cloudflare seems to have recovered as we are seeing traffic level back to normal.

Created
Nov 18 at 02:06am HST

Cloudflare, a hosting provider, is experiencing a major incident, which is causing our services to return 500s on most requests.