Back to overview
Degraded

High latency on mempool

Sep 19, 2025 at 11:37pm UTC
Affected services
mempool.merkle.io

Resolved
Sep 19, 2025 at 11:45pm UTC

We have identifies the root cause, rolled out a fix. Services have recovered.

Created
Sep 19, 2025 at 11:37pm UTC

We are investigating high latency on mempool requests