Back to overview
Degraded
High latency on RPC and Mempool.
Aug 21 at 09:40am HDT
Affected services
mempool.merkle.io
Resolved
Aug 21 at 10:25am HDT
Cloudflare has resolved their incident
Affected services
Updated
Aug 21 at 10:07am HDT
We have isolated this issue to an incident happening with one of our providers: Cloudflare.
Affected services
Created
Aug 21 at 09:40am HDT
We are currently investigating higher latencies and timeouts on RPC and mempool.
Affected services